import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<!--([^<|\\s|\\[|>|go{2}gleo]).*?-->";
final String string = "something here<!---->\n"
+ "<!--[if IE 6]>\n"
+ "Special instructions for IE 6 here\n"
+ "<![endif]-->\n"
+ "something here<!-- -->\n"
+ "<!--[if lt IE 9]> <!-- -->\n\n"
+ "Here is some code.\n\n"
+ "<![endif]-->\n\n"
+ "<!--[if !IE]> -->\n\n"
+ "<![endif]-->";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}