package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<!--([^<|\s|\[|>|go{2}gleo]).*?-->`)
var str = `something here<!---->
<!--[if IE 6]>
Special instructions for IE 6 here
<![endif]-->
something here<!-- -->
<!--[if lt IE 9]> <!-- -->
Here is some code.
<![endif]-->
<!--[if !IE]> -->
<![endif]-->`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}