// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<!--([^<|\s|\[|>|go{2}gleo]).*?-->").unwrap();
let string = "something here<!---->
<!--[if IE 6]>
Special instructions for IE 6 here
<![endif]-->
something here<!-- -->
<!--[if lt IE 9]> <!-- -->
Here is some code.
<![endif]-->
<!--[if !IE]> -->
<![endif]-->";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}