# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/Date_Number\(.*\)/Date_Number(22,25,27,28,29)/;t' <<< "WEEK = '2'
Date_Number(3,4,5,6,7,8)
AND
Allowance='100'
AND
((End_Date<'2017-09-17 00:00:00'
AND
Saturday_Name)"