using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Date_Number\(.*\)";
string substitution = @"Date_Number(22,25,27,28,29)";
string input = @"WEEK = '2'
Date_Number(3,4,5,6,7,8)
AND
Allowance='100'
AND
((End_Date<'2017-09-17 00:00:00'
AND
Saturday_Name)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}