package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Date_Number\(.*\)`)
var str = []byte(`WEEK = '2'
Date_Number(3,4,5,6,7,8)
AND
Allowance='100'
AND
((End_Date<'2017-09-17 00:00:00'
AND
Saturday_Name)`)
var substitution = []byte("Date_Number(22,25,27,28,29)")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}