#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "Date_Number\(.*\)"
Local $sString = "WEEK = '2'" & @CRLF & _
"Date_Number(3,4,5,6,7,8)" & @CRLF & _
"AND" & @CRLF & _
"Allowance='100'" & @CRLF & _
"AND" & @CRLF & _
"((End_Date<'2017-09-17 00:00:00'" & @CRLF & _
"AND" & @CRLF & _
"" & @CRLF & _
"Saturday_Name)"
Local $sSubst = "Date_Number(22,25,27,28,29)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)