import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Date_Number\\(.*\\)";
final String string = "WEEK = '2'\n"
+ "Date_Number(3,4,5,6,7,8)\n"
+ "AND\n"
+ "Allowance='100'\n"
+ "AND\n"
+ "((End_Date<'2017-09-17 00:00:00'\n"
+ "AND\n\n"
+ "Saturday_Name)";
final String subst = "Date_Number(22,25,27,28,29)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}