const regex = /Date_Number\(.*\)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Date_Number\\(.*\\)', '')
const str = `WEEK = '2'
Date_Number(3,4,5,6,7,8)
AND
Allowance='100'
AND
((End_Date<'2017-09-17 00:00:00'
AND
Saturday_Name)`;
const subst = `Date_Number(22,25,27,28,29)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);