re = /Date_Number\(.*\)/
str = 'WEEK = \'2\'
Date_Number(3,4,5,6,7,8)
AND
Allowance=\'100\'
AND
((End_Date<\'2017-09-17 00:00:00\'
AND
Saturday_Name)'
subst = 'Date_Number(22,25,27,28,29)'
result = str.sub(re, subst)
# Print the result of the substitution
puts result