using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bwidth:\s*[.0-9]*pt;";
string substitution = @"";
string input = @"width:453.1pt;border:solid windowtext 1.0pt; ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}