const regex = /\bwidth:\s*[.0-9]*pt;/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bwidth:\\s*[.0-9]*pt;', 'g')
const str = `width:453.1pt;border:solid windowtext 1.0pt; `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);