import re
regex = re.compile(r"\bwidth:\s*[.0-9]*pt;")
test_str = "width:453.1pt;border:solid windowtext 1.0pt; "
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)