// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\bwidth:\s*[.0-9]*pt;").unwrap();
let string = "width:453.1pt;border:solid windowtext 1.0pt; ";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}