# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(-?\d+)(?:\.0+|(\.\d*?)0+|\.+)?$/$1$2/gm;t' <<< "50.000
50
50.100
50.040
50.
50.000
=> 50
50.500
=> 50.5
-5
50"