package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(-?\d+)(?:\.0+|(\.\d*?)0+|\.+)?$`)
var str = `50.000
50
50.100
50.040
50.
50.000
=> 50
50.500
=> 50.5
-5
50`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}