import Foundation
let pattern = #"^(-?\d+)(?:\.0+|(\.\d*?)0+|\.+)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
50.000
50
50.100
50.040
50.
50.000
=> 50
50.500
=> 50.5
-5
50
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)