import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(-?\\d+)(?:\\.0+|(\\.\\d*?)0+|\\.+)?$";
final String string = "50.000\n"
+ "50\n"
+ "50.100\n"
+ "50.040\n"
+ "50.\n"
+ "50.000\n"
+ " => 50\n"
+ "50.500\n"
+ " => 50.5\n"
+ "-5\n"
+ "50";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}