use strict;
my $str = '50.000
50
50.100
50.040
50.
50.000
=> 50
50.500
=> 50.5
-5
50';
my $regex = qr/^(-?\d+)(?:\.0+|(\.\d*?)0+|\.+)?$/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";