import re
regex = re.compile(r"^(-?\d+)(?:\.0+|(\.\d*?)0+|\.+)?$", flags=re.MULTILINE)
test_str = ("50.000\n"
"50\n"
"50.100\n"
"50.040\n"
"50.\n"
"50.000\n"
" => 50\n"
"50.500\n"
" => 50.5\n"
"-5\n"
"50")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)