#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(-?\d+)(?:\.0+|(\.\d*?)0+|\.+)?$"
Local $sString = "50.000" & @CRLF & _
"50" & @CRLF & _
"50.100" & @CRLF & _
"50.040" & @CRLF & _
"50." & @CRLF & _
"50.000" & @CRLF & _
" => 50" & @CRLF & _
"50.500" & @CRLF & _
" => 50.5" & @CRLF & _
"-5" & @CRLF & _
"50"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)