const regex = /^(-?\d+)(?:\.0+|(\.\d*?)0+|\.+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(-?\\d+)(?:\\.0+|(\\.\\d*?)0+|\\.+)?$', 'gm')
const str = `50.000
50
50.100
50.040
50.
50.000
=> 50
50.500
=> 50.5
-5
50`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);