// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(-?\d+)(?:\.0+|(\.\d*?)0+|\.+)?$").unwrap();
let string = "50.000
50
50.100
50.040
50.
50.000
=> 50
50.500
=> 50.5
-5
50";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}