# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*?(cat.*?){1})cat/\1Bull/gm;t' <<< "bear cat goose mouse horse pig cat foo cat cow"