use strict;
my $str = 'bear cat goose mouse horse pig cat foo cat cow';
my $regex = qr/^(.*?(cat.*?){1})cat/mp;
my $subst = '\\1Bull';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";