const regex = /^(.*?(cat.*?){1})cat/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?(cat.*?){1})cat', 'gm')
const str = `bear cat goose mouse horse pig cat foo cat cow`;
const subst = `\1Bull`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);