$re = '/^(.*?(cat.*?){1})cat/m';
$str = 'bear cat goose mouse horse pig cat foo cat cow';
$subst = "\1Bull";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;