// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*?(cat.*?){1})cat").unwrap();
let string = "bear cat goose mouse horse pig cat foo cat cow";
let substitution = "\\1Bull";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}