import re
regex = re.compile(r"^(.*?(cat.*?){1})cat", flags=re.MULTILINE)
test_str = "bear cat goose mouse horse pig cat foo cat cow"
subst = "\\1Bull"
result = regex.sub(subst, test_str)
if result:
print(result)