import Foundation
let pattern = #"^(.*?(cat.*?){1})cat"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"bear cat goose mouse horse pig cat foo cat cow"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1Bull"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)