package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?(cat.*?){1})cat`)
var str = `bear cat goose mouse horse pig cat foo cat cow`
var substitution = "\1Bull"
fmt.Println(re.ReplaceAllString(str, substitution))
}