#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([A-Z\-0-9\-\0-9]{1,})"
Local $sString = "PFK-720086-03"
Local $sSubst = "PFK-720086-03"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)