$re = '/([A-Z\-0-9\-\0-9]{1,})/';
$str = 'PFK-720086-03';
$subst = "PFK-720086-03";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;