import re
regex = re.compile(r"([A-Z\-0-9\-\0-9]{1,})")
test_str = "PFK-720086-03"
subst = "PFK-720086-03"
result = regex.sub(subst, test_str)
if result:
print(result)