re = /([A-Z\-0-9\-\0-9]{1,})/
str = 'PFK-720086-03'
subst = 'PFK-720086-03'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result