using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z\-0-9\-\0-9]{1,})";
string substitution = @"PFK-720086-03";
string input = @"PFK-720086-03";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}