import Foundation
let pattern = #"([A-Z\-0-9\-\0-9]{1,})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"PFK-720086-03"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"PFK-720086-03"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)