const regex = /([A-Z\-0-9\-\0-9]{1,})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z\\-0-9\\-\\0-9]{1,})', 'g')
const str = `PFK-720086-03`;
const subst = `PFK-720086-03`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);