# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|<|\b)(\S+?\.com)(\b|>|$)/<a href="https:\/\/$2" target="_blank">$2<\/a>/g;t' <<< "I am google.com"