import Foundation
let pattern = #"(^|<|\b)(\S+?\.com)(\b|>|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"I am google.com"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href="https://$2" target="_blank">$2</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)