use strict;
my $str = 'I am google.com';
my $regex = qr/(^|<|\b)(\S+?\.com)(\b|>|$)/p;
my $subst = '<a href="https://$2" target="_blank">$2</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";