#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(^|<|\b)(\S+?\.com)(\b|>|$)"
Local $sString = "I am google.com"
Local $sSubst = "<a href="https://$2" target="_blank">$2</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)