// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(^|<|\b)(\S+?\.com)(\b|>|$)").unwrap();
let string = "I am google.com";
let substitution = "<a href=\"https://$2\" target=\"_blank\">$2</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}