import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|<|\\b)(\\S+?\\.com)(\\b|>|$)";
final String string = "I am google.com";
final String subst = "<a href=\"https://$2\" target=\"_blank\">$2</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}