using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|<|\b)(\S+?\.com)(\b|>|$)";
string substitution = @"<a href=""https://$2"" target=""_blank"">$2</a>";
string input = @"I am google.com";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}