package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\[([^]]*)]`)
var str = `[img src="https://www.example.com/assets/images/logo-default-120x50.png" width="120px" height="80px"]
[br][br]`
var substitution = "<$1 />"
fmt.Println(re.ReplaceAllString(str, substitution))
}