$re = '/\[([^]]*)]/s';
$str = '[img src="https://www.example.com/assets/images/logo-default-120x50.png" width="120px" height="80px"]
[br][br]';
$subst = "<$1 />";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;