import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[([^]]*)]";
final String string = "[img src=\"https://www.example.com/assets/images/logo-default-120x50.png\" width=\"120px\" height=\"80px\"]\n\n"
+ "[br][br]";
final String subst = "<$1 />";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}