const regex = /\[([^]]*)]/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[([^]]*)]', 'gs')
const str = `[img src="https://www.example.com/assets/images/logo-default-120x50.png" width="120px" height="80px"]
[br][br]`;
const subst = `<$1 />`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);