# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[([^]]*)]"
test_str = ("[img src=\"https://www.example.com/assets/images/logo-default-120x50.png\" width=\"120px\" height=\"80px\"]\n\n"
"[br][br]")
subst = "<$1 />"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.